线段树 Balanced Lineup

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2..  N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2..  NQ+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1..  Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

这是线段树的模板题,唯一的坑点就是我不知道为什么题目中说n<50000,但实际上我的结构体开到150000才够。后来想通了,n只是代表最底层的数目,而总数自然是要大于他的,我觉得两倍就行了,但用100000的话我不知道为什么不过。

#include <stdio.h>

const int maxn=500000+10;

int mi,ma;

struct btree
{
	int l,r;
	int max1,min1;
}tree[maxn];

int max(int x,int y)
{
	if(x>y)
		return x;
	else
		return y;
}

int min(int x,int y)
{
	if(x<y)
		return x;
	else
		return y;
}

void build(int l1,int r1,int k)
{
	int mid=(l1+r1)/2;
	tree[k].l=l1;
	tree[k].r=r1;
	tree[k].max1=0;
	tree[k].min1=0x3f3f3f3f;
	if(l1==r1) return ;
	build(l1,mid,2*k);
	build(mid+1,r1,2*k+1);
}

void insert(int v,int i,int k)
{
	if(tree[k].l==tree[k].r)
	{
		tree[k].max1=v,tree[k].min1=v;
		return ;
	}
	int mid=(tree[k].l+tree[k].r)/2;
	if(i<=mid)
		insert(v,i,2*k);
	else
		insert(v,i,2*k+1);
	tree[k].max1=max(tree[2*k].max1,tree[2*k+1].max1);
	tree[k].min1=min(tree[2*k].min1,tree[2*k+1].min1);
}

void search(int l1,int r1,int k)
{
	if(tree[k].l==l1&&tree[k].r==r1)
	{
		mi=min(mi,tree[k].min1);
		ma=max(ma,tree[k].max1);
		return ;
	}
	int mid=(tree[k].l+tree[k].r)/2;
	if(r1<=mid)
		search(l1,r1,2*k);
	else if(l1>=mid+1)
		search(l1,r1,2*k+1);
	else
	{
		search(l1,mid,2*k);
		search(mid+1,r1,2*k+1);
	}
}

int main()
{
	int n,q;
	scanf("%d%d",&n,&q);
	int i;
	build(1,n,1);
	for(i=1;i<=n;i++)
	{
		int v;
		scanf("%d",&v);
		insert(v,i,1);
	}
	for(i=0;i<q;i++)
	{
		mi=0x3f3f3f3f;
		ma=0;
		int l,r;
		scanf("%d%d",&l,&r);
		search(l,r,1);
		int ans=ma-mi;
		printf("%d\n",ans);
	}	
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值