动态规划 Making the Grade

Description

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

A  B  1| + |  A  B  2| + ... + |  AN -  BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

由于每个改变的都必然要变成其他的一个包含在数组内的点,所以我们利用动归dp[i][j],表示到第i个点用到第j高的数,那么递推关系就是dp[i][j]=dp[i-1]中最小的值加上a[i]和b[j]差的绝对值,最后再找dp[n][j]中的最小值就行了

#include <stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;

const int maxn=2000+10;

int a[maxn];
int b[maxn];
int dp[maxn][maxn];
int n;

int min(int x,int y)
{
	if(x<y)
		return x;
	else
		return y;
}

int cmp(int x,int y)
{
	return x>y;
}

void solve()
{
	memset(dp,0x3f,sizeof(dp));
	int i,j;
	for(i=1;i<=n;i++)
		dp[1][i]=abs(a[1]-b[i]);
	for(i=2;i<=n;i++)
	{
		int mins=0x3f3f3f3f;
		for(j=1;j<=n;j++)
		{
			mins=min(mins,dp[i-1][j]);
			dp[i][j]=mins+abs(a[i]-b[j]);
		}
	}
}

int main()
{
	int i;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		b[i]=a[i];
	}
	int ans=0x3f3f3f3f;
	sort(b+1,b+1+n);
	solve();
	for(i=1;i<=n;i++)
	{
		ans=min(ans,dp[n][i]);
	}
	sort(b+1,b+1+n,cmp);
	solve();
	for(i=1;i<=n;i++)
	{
		ans=min(ans,dp[n][i]);
	}
	printf("%d\n",ans);
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值