矩阵乘法 Matrix Power Series

Description

Given a n × n matrix A and a positive integer k, find the sum S = A + A2 + A3 + … + Ak.

Input

The input contains exactly one test case. The first line of input contains three positive integers n (n ≤ 30), k (k ≤ 109) and m (m < 104). Then follow n lines each containing n nonnegative integers below 32,768, giving A’s elements in row-major order.

Output

Output the elements of S modulo m in the same way as A is given.

Sample Input

2 2 4
0 1
1 1

Sample Output

1 2
2 3

这题关键就是矩阵的快速幂,和如何快速求和,这两点都是由二分法来实现的,求和的二分法就是把一段和看成前半段和后半段,求和就是求前半段的和,加上前半段的和乘以一个原数组的(k/2或k/2+1)次方,这样一直递归到1,再返回就可以求出解了。

#include <stdio.h>
#include <string.h>

struct node
{
	int a[35][35];
	node(){memset(a,0,sizeof(a));};
}plus,init;

int n,k,m;

node mul(node p1,node p2)
{
	node p3;
	int i,j,l;
	for(i=0;i<n;i++)
		for(j=0;j<n;j++)
			for(l=0;l<n;l++)
			{
				p3.a[i][j]=(p3.a[i][j]+p1.a[i][l]*p2.a[l][j])%m;
			}
	return p3;
}

node add(node p1,node p2)
{
	node p3;
	int i,j;
	for(i=0;i<n;i++)
		for(j=0;j<n;j++)
		{
			p3.a[i][j]=(p1.a[i][j]+p2.a[i][j])%m;
		}
	return p3;
}

node multi(int k1)
{
	node init1=init,plus1=plus;
	while(k1)
	{
		if(k1&1)
		{
			init1=mul(init1,plus1);
		}
		k1>>=1;
		plus1=mul(plus1,plus1);
	}
	return init1;
}

node solve(int k)
{
	if(k==1)
		return plus;
	if(k&1)
	{
		node tmp=solve(k/2);
		node tmpk=multi(k/2+1);
		return add(tmpk,add(tmp,mul(tmp,tmpk)));
	}
	else
	{
		node tmp=solve(k/2);
		node tmpk=multi(k/2);
		return add(tmp,mul(tmp,tmpk));
	}
}

int main()
{
	scanf("%d%d%d",&n,&k,&m);
	int i,j;
	for(i=0;i<n;i++)
		for(j=0;j<n;j++)
		{	
			scanf("%d",&plus.a[i][j]);
			plus.a[i][j]=(plus.a[i][j])%m;
		}
	for(i=0;i<n;i++)
	{
		init.a[i][i]=1;
	}
	node ans=solve(k);
	for(i=0;i<n;i++)
	{
		for(j=0;j<n-1;j++)
			printf("%d ",ans.a[i][j]);
		printf("%d\n",ans.a[i][j]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值