Fibonacci

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.


这题其实就是求题目中给出的那个矩阵的n次方,我们利用矩阵的快速幂乘法即可求出(我的代码中是用二分法来实现的)。

#include <stdio.h>
#include <string.h>
const int a1[2][2]={{1,0},{0,1}};
const int a2[2][2]={{1,1},{1,0}};

struct node
{
	int a[2][2];
}init,plus;

node mul(node p1,node p2)
{
	node p3;
	memset(p3.a,0,sizeof(p3.a));
	int i,j,l;
	for(i=0;i<2;i++)
		for(j=0;j<2;j++)
			for(l=0;l<2;l++)
			{
				p3.a[i][j]=(p3.a[i][j]+p1.a[i][l]*p2.a[l][j])%10000;
			}
	return p3;
}

node multi(int k1)
{
	node init1=init;
	while(k1)
	{
		if(k1&1)
		{
			init1=mul(init1,plus);
		}
		k1>>=1;
		plus=mul(plus,plus);
	}
	return init1;
}

int main()
{
	int k;
	while(~scanf("%d",&k))
	{
		memcpy(init.a,a1,sizeof(a1));
		memcpy(plus.a,a2,sizeof(a1));
		if(k==-1)
			break;
		node ans=multi(k);
		printf("%d\n",ans.a[0][1]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值