POJ 3067 Japan 树状数组

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

这题关键就在于如何才算相交,要求应该是n比上一个大,m比上一个小,我们可以先将所有数据按照从n的从小到大,再从m的从小到大,这样同一个点出发的会依次增加上去,这样新增加的点与其他线的交点数就是在这点之后的所有的点的值的和,我们用两个sum一减就行。(语言表达不行,你们可以直接看代码....)

坑点在于为什么要用__int64?可以想象一下极限的情况,第一个点把所有的都连了的话第二个点就是999加到1,第三个点就是1998加到1,这样加到最后就是999*999再加到1;所以得用__int64;

#include <stdio.h>
#include<algorithm>
#include <string.h>
using namespace std;

__int64 c[1000+10];
int n;

struct node
{
	int st,en;
}road[1000000+10];



int cmp(node x,node y)
{
	if(x.st!=y.st)
		return x.st<y.st;
	else
		return x.en<y.en;
}

int lowbit(int k)  
{  
    return (k&(-k));  
}


int sum(int x)  		//求和
{  
    __int64 ret = 0;  
    while(x>0)  
    {  
        ret+=c[x];  
        x-=lowbit(x);  
    }  
    return ret;  
}  

void add(int x,int d)  		//修改节点的值
{  
    while(x<=n)  
    {  
        c[x]+=d;  
        x+=lowbit(x);  
    }  
}

int main()
{
	int t;
	scanf("%d",&t);
	int icase;
	for(icase=1;icase<=t;icase++)
	{
		memset(c,0,sizeof(c));
		int n1,m1,k;
		scanf("%d%d%d",&n1,&m1,&k);
		int i,j;
		n=m1;
		__int64 ans=0;
		for(i=0;i<k;i++)
		{
			scanf("%d%d",&road[i].st,&road[i].en);
		}
		sort(road,road+k,cmp);
		for(i=0;i<k;i++)
		{
			ans+=sum(m1)-sum(road[i].en);
			add(road[i].en,1);
		}
		printf("Test case %d: %I64d\n",icase,ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值