HDU 4405 Aeroplane chess(概率DP求期望)

Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N. 

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid. 

Please help Hzz calculate the expected dice throwing times to finish the game. 

Input

There are multiple test cases. 
Each test case contains several lines. 
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000). 
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).   
The input end with N=0, M=0. 

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point. 

Sample Input

2 0
8 3
2 4
4 5
7 8
0 0

Sample Output

1.1667
2.3441

这题的主要想法是如果我们记dp[i]为从i到n需要多少步的话那因为从i走一步可能到i+1~i+6,所以说i到n的期望值就是1(无论如何都要自己走的一步)+dp[i+1]/6~dp[i+6]/6,因为从i点到那些点的几率都是1/6,而如果超过了n,因为我们初始化时就把dp都归零了,所以说相当于就是直接到达n点,所以说都不需要分类讨论了。

#include <stdio.h>
#include <string.h>

int road[100000];
double dp[100000];

int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m)&&(m+n))
	{
		memset(dp,0,sizeof(dp));
		memset(road,0,sizeof(road));
		int i,j;
		for(i=0;i<m;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			road[x]=y;
		}
		for(i=n-1;i>=0;i--)
		{
			if(road[i]!=0)
				dp[i]=dp[road[i]];
			else
			{
				for(j=1;j<=6;j++)
					dp[i]+=dp[i+j]/(6.0);
				dp[i]++;
			}
		}
		printf("%.4lf\n",dp[0]);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值