杭电1241Oil Deposits DFS 搜索

19 篇文章 0 订阅

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30422    Accepted Submission(s): 17621


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2

2

import java.util.*;  
class Main{  
    public static void main(String args[]){  
        Scanner sc=new Scanner(System.in);  
        while(sc.hasNext()){  
            int n=sc.nextInt();  
            int m=sc.nextInt();  
            if(n==0&&m==0){  
                break;  
            }  
            char a[][]=new char[n][m];          //字符数组装油田和*  
            boolean vis[][]=new boolean[n][m];  //标记数组,说明该位置是否被用过  
            for(int i=0;i<n;i++){  
                String str=sc.next();  
                a[i]=str.toCharArray();  
            }  
            for(int i=0;i<n;i++){  
                for(int j=0;j<m;j++){  
                    vis[i][j]=true;         //初始化标记数组,为true说明没被用过  
                }  
            }  
            int count=0;        //油田数量  
            for(int i=0;i<n;i++){  
                for(int j=0;j<m;j++){  
                    if(a[i][j]=='@'&&vis[i][j]){    //如果这个位置是油田,且没用被用过  
                        vis[i][j]=false;    //标记这个位置被用过  
                        dfs(a,vis,i,j,n,m); //从这个位置开始搜索  
                          
                        count++;  
                    }  
                }  
            }  
            System.out.println(count);  
        }  
    }  
    public static void dfs(char a[][],boolean vis[][],int x,int y,int n,int m){  
        int t[][]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};  
        //上下左右,左上左下,右上右下,八个方向  
        for(int i=0;i<8;i++){  
            int nx=x+t[i][0];       //遍历该位置的八个方向  
            int ny=y+t[i][1];  
            if(nx>=0&&nx<n&&ny>=0&&ny<m){       //当新的位置还在范围内时,不会越界  
                if(a[nx][ny]=='@'&&vis[nx][ny]){      
                    //如果还是油田,则接着搜索该位置的八个方向,并标记此位置已经被用过  
                    vis[nx][ny]=false;  
                    dfs(a,vis,nx,ny,n,m);  
                }  
            }  
        }  
    }  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值