题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5933
题目描述:
Problem Description
ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.
There are N working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into K new blocks by the following two operations:
- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.
Now the CEO wants to know the minimum operations to re-arrange current blocks into K block with equal size, please help him.
Input
First line contains an integer T, which indicates the number of test cases.
Every test case begins with one line which two integers N and K, which is the number of old blocks and new blocks.
The second line contains N numbers a1, a2, ⋯, aN, indicating the size of current blocks.
Limits
1≤T≤100
1≤N≤105
1≤K≤105
1≤ai≤105
Output
For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum operations.
If the CEO can't re-arrange K new blocks with equal size, y equals -1.
Sample Input
3 1 3 14 3 1 2 3 4 3 6 1 2 3
Sample Output
Case #1: -1 Case #2: 2 Case #3: 3
Source
题目大意及分析:
给你两个整数n和k,接下来输入n个数,问能不能把这n个数均分为k个数,对于每个数只能进行两种操作,即和相邻的数相加或者拆分成两个数,本体通过贪心求解,从头到尾贪一遍
AC代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
using namespace std;
const long long int maxn=100005;
long long int T,n,k,sum,step,num=1;
long long int s[maxn];
int main()
{
scanf("%lld",&T);
while(T--)
{
scanf("%lld%lld",&n,&k);
sum=0;
for(long long int i=1;i<=n;i++)
{
scanf("%lld",&s[i]);
sum+=s[i];
}
if(sum%k)
{
printf("Case #%lld: -1\n",num++);
continue;
}
sum/=k;
step=0;
for(long long int i=1;i<=n;i++)
{
if(s[i]==0||s[i]==sum)
continue;
if(s[i]>sum)
{
step++;
s[i]-=sum;
i--;
}
else
{
long long int x=s[i];
for(int j=i+1;j<=n;j++)
{
if(x+s[j]<sum)
{
x+=s[j];
i++;
step++;
}
else if(x+s[j]==sum)
{
i++;
step++;
break;
}
else
{
s[j]-=(sum-x);
step+=2;
break;
}
}
}
}
printf("Case #%lld: %lld\n",num++,step);
}
return 0;
}