hdu 5933 ArcSoft's Office Rearrangement【模拟】

ArcSoft's Office Rearrangement

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are N working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into K new blocks by the following two operations:

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the minimum operations to re-arrange current blocks into K block with equal size, please help him.
 

Input
First line contains an integer T , which indicates the number of test cases.

Every test case begins with one line which two integers N and K , which is the number of old blocks and new blocks.

The second line contains N numbers a1 , a2 , , aN , indicating the size of current blocks.

Limits
1T100
1N105
1K105
1ai105

Output
For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum operations.

If the CEO can't re-arrange K new blocks with equal size, y equals -1.

Sample Input
3
1 3
14
3 1
2 3 4
3 6
1 2 3
Sample Output
Case #1: -1
Case #2: 2
Case #3: 3

题目大意:

给你N个数,让你分成K个相等的数,操作有两种:

①合并相邻的两个数,得到的数为两个数的和。

②分开一个数,得到的两个数为那个数的拆分。

问最少需要操作多少次。


思路:


1、首先我们将所有数加在一起,如果其和是K的倍数,那么一定能够得到结果,否则输出-1、


2、如果有解,分析到合并操作只能合并相邻的两个数,那么我们对应这样处理:

①将所有数纳入双端队列中,每次取队头元素,直到处理队列为空为止。

②如果队头元素等于sum/k,那么这个数不需要进行处理,否则如果这个数大于sum/k,那么我们对应将这个数一直拆分,直到不能拆分为止。

③如果此时元素小于sum/k,那么对应将这个数累加下一个队头元素,一直进行下去,如果加到了sum/k,那么这个数就不需要继续处理了,否则如果大于sum/k,那么我们再将这个数重新纳入队头。重新进行操作2.


3、相对处理好一些代码细节即可。


Ac代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<deque>
using namespace std;
#define ll __int64
ll a[100005];
int main()
{
    int t;
    int kase=0;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        ll kk;
        scanf("%d%I64d",&n,&kk);
        ll sum=0;
        deque<ll >s;
        for(int i=0;i<n;i++)
        {
            scanf("%I64d",&a[i]);
            sum+=a[i];
            s.push_back(a[i]);
        }
        printf("Case #%d: ",++kase);
        if(sum%kk!=0)
        {
            printf("-1\n");
            continue;
        }
        ll k=sum/kk;
        int output=0;
        while(!s.empty())
        {
            ll u=s.front();
            s.pop_front();
            if(u==k)continue;
            else if(u>k)
            {
                output+=u/k;
                u%=k;
                if(u==0)output--;
            }
            if(u==0)continue;
            if(u<k)
            {
                while(1)
                {
                    ll v=s.front();
                    s.pop_front();
                    u+=v;
                    output++;
                    if(u==k)break;
                    if(u>k)
                    {
                        s.push_front(u);
                        break;
                    }
                }
            }
        }
        printf("%d\n",output);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值