HDU-5933 ArcSoft's Office Rearrangement(思维)

ArcSoft's Office Rearrangement

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 156    Accepted Submission(s): 75


Problem Description
ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are   N  working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into   K  new blocks by the following two operations:

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the   minimum  operations to re-arrange current blocks into   K  block with equal size, please help him.
 

Input
First line contains an integer   T , which indicates the number of test cases.

Every test case begins with one line which two integers   N  and   K , which is the number of old blocks and new blocks.

The second line contains   N  numbers   a1 ,   a2 ,   ,   aN , indicating the size of current blocks.

Limits
1T100
1N105
1K105
1ai105
 

Output
For every test case, you should output   'Case #x: y', where   x  indicates the case number and counts from   1  and   y  is the minimum operations.

If the CEO can't re-arrange   K  new blocks with equal size,   y  equals   -1.
 

Sample Input
  
  
3 1 3 14 3 1 2 3 4 3 6 1 2 3
 

Sample Output
  
  
Case #1: -1 Case #2: 2 Case #3: 3
 

Source
 


题意:

给你n个数,你有两个操作:

1.将相邻两个数合并 2.将一个数拆分成两个数

将这n个数变成k个数,要求操作数最小。


思路:

开始理解叉了,题意也没怎么看清楚,而且因为题意坑了龙哥(被两个队友坑了),后来一直没想清楚,后来看了题解,才知道思路开始是相似的,但是各种差错,各种蹭规律,不说了。

因为我们可以很明显的找到最大次数,即  n-1 + k-1,n个合并成一个,n-1步,1个拆分成k个,k-1步,然后过程中可以省掉一些步数,即 pre[i] % aver == 0(pre[i]为前缀和),此时可以省去一个合并拆分操作。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

typedef long long ll;
const int N = 100005;
ll a[N],pre[N];

int main()
{
    int t,n,k;
    cin >> t;
    for(int ca = 1;ca <= t;ca++)
    {
        scanf("%d%d",&n,&k);
        ll sum = 0;
        for(int i = 1;i <= n;i++)
        {
            scanf("%lld",&a[i]);
            sum += a[i];
            pre[i] = pre[i-1] + a[i];
        }

        printf("Case #%d: ",ca);
        if(sum % k != 0)
            printf("-1\n");
        else
        {
            ll aver = sum / k,cnt = 0;
            for(int i = 1;i < n;i++)
            {
                if(pre[i] % aver == 0)
                    cnt++;
            }
            //printf("%lld\n",cnt);
            ll ans = n - 1 + k - 1 - cnt * 2;
            printf("%lld\n",ans);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值