poj 1971 Parallelogram Counting

poj 1971 Parallelogram Counting
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

Input starts with an integer T (≤ 15), denoting the number of test cases.

The first line of each test case contains an integer n (1 ≤ n ≤ 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

For each case, print the case number and the number of parallelograms that can be formed.

Sample Input

2

6

0 0

2 0

4 0

1 1

3 1

5 1

7

-2 -1

8 9

5 7

1 1

4 8

2 0

9 8

Sample Output

Case 1: 5

Case 2: 6


找所有的连线的中点。相同的就加一下,因为两条中点相同的直线可以构成平行四边形。


//数平行四边形?
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn = 1010;
struct node{
	int x,y;
};

node mid[maxn*maxn],s[maxn];

bool cmp(node a,node b){
	return a.x == b.x?a.y<b.y:a.x<b.x;
}

int main(){
	int t,n,text = 1;
	int next,sum,cnt;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(int i=0; i<n; i++){
			scanf("%d%d",&s[i].x,&s[i].y);
			
		}
		int top = 0;
		for(int i=0; i<n; i++){
			for(int j=i+1; j<n; j++){
				mid[top].x = s[i].x+s[j].x;
				mid[top++].y = s[i].y+s[j].y;
			}
		}
		sort(mid,mid+top,cmp);
		next = 0;sum = 1;cnt = 0;
		for(int i=1; i<top; i++){
			if(mid[i].x == mid[next].x && mid[i].y == mid[next].y){
				sum++;
			}
			else{
				next = i;
				cnt+=sum*(sum-1)/2;
				sum = 1;
			}
		}
		printf("Case %d: %d\n",text++,cnt);
			} 
	
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值