A/B
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4659 Accepted Submission(s): 3627
Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。
Sample Input
2
1000 53
87 123456789
Sample Output
7922
6060
好吧,我承认这是一道简单的求逆元的水题(原来觉得多高级的)
何为逆元,就是
x
满足
a∗b−1=a∗x mod m
b∗x=1 mod m
这不就是扩展欧几里得吗!!
b∗x+m∗y=1 mod m
至于扩展欧几里得,请参考:
下面是代码:
#include<cstdio>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define MAXN
#define MAXM
#define MOD 9973
#define INF 0x3f3f3f3f
typedef long long int LL;
LL A,B;
LL exgcd(LL a,LL b,LL &x,LL&y)
{
if(b==0)
{
x=1,y=0;
return a;
}
LL rn=exgcd(b,a%b,x,y);
LL t=x;
x=y;
y=t-(a/b)*y;
return rn;
}
LL getny(LL a,LL mod)
{
LL x,y;
exgcd(a,mod,x,y);
x=x%MOD;
if(x<0)x+=mod;
return x;
}
int main()
{
int Case;
scanf("%d",&Case);
while(Case--)
{
scanf("%I64d%I64d",&A,&B);
printf("%I64d\n",((A*getny(B,MOD)%MOD)%MOD));
}
}