[JAVA](PAT)1008 ELEVATOR (20)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题目大意

给定一串整型串,第一个整型N是总共有多少个请求,后面的整型串是请求的楼层。

每上升一层花费6秒,下降一层花费4秒,停在一层花费5秒。

分析:

使用now变量记录当前楼层,和下一个请求楼层进行对比,累加花费时间,最后输出答案

Java实现

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Main {
    public static void main(String[] args) throws Exception{
    	BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] line = br.readLine().split(" ");
        int num = Integer.valueOf(line[0]);
        int floor[] = new int[num];
        for(int i = 1; i <= num; i++){
            floor[i - 1] = Integer.valueOf(line[i]);
        }
        br.close();
        int total = 0;
        int now = 0;
        for(int i : floor){
            if(i > now){
                total = total + 5 +6 * (i - now);
                now = i;
            }else
                if(i < now){
                total = total + 5 + 4 * (now - i);
                now = i;
                }else
                    if(i == now){
                        total = total + 5;
                    }
        }
        System.out.print(total);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值