PAT A1086. Tree Traversals Again (25)

原文链接: PAT A1086. Tree Traversals Again (25)

上一篇: PAT A1020. Tree Traversals (25)

下一篇: PAT A1102. Invert a Binary Tree (25)

1086. Tree Traversals Again (25)

https://www.patest.cn/contests/pat-a-practise/1086

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

08225424_vuFf.jpg
Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std;

const int MAX = 111;
struct Node {
	int data;
	Node *left, *right;
	Node() {}
	Node(int data) :data(data) {
		left = right = NULL;
	}
};

int pre[MAX], in[MAX], post[MAX];
int n;	//节点个数 

		//当前二叉树的先序区间[prel,preR],中序区间[inL,inR]
Node* create(int preL, int preR, int inL, int inR) {
	if (preL > preR)
		return NULL;
	Node *root = new Node(pre[preL]);
	int index;
	for (index = inL; in[index] != pre[preL]; index++);
	int num = index - inL;
	root->left = create(preL + 1, preL + num, inL, index - 1);
	root->right = create(preL + num + 1, preR, index + 1, inR);
	return root;
}

int num = 0;	//已输出节点个数

void postOrder(Node *root) {
	if (root == NULL)
		return;
	postOrder(root->left);
	postOrder(root->right);
	printf("%d", root->data);
	num++;
	if (num < n)printf(" ");
}

int main(int argc, char *argv[]) {
	scanf("%d", &n);
	char str[5];
	stack<int> st;
	int t, preIndex = 0, inIndex = 0;
	for (int i = 0; i < 2 * n; i++) {
		scanf("%s", str);
		if (strlen(str) == 4) {
			scanf("%d", &t);
			pre[preIndex++] = t;
			st.push(t);
		} else {
			in[inIndex++] = st.top();
			st.pop();
		}
	}
	Node* root = create(0, n - 1, 0, n - 1);
	postOrder(root);
	return 0;
}

题目大意:用栈的形式给出一棵二叉树的建立的顺序,求这棵二叉树的后序遍历
分析:栈实现的是二叉树的中序遍历(左根右),而每次push入值的顺序是二叉树的前序遍历(根左右),所以该题可以用二叉树前序和中序转后序的方法做~~
root为当前子树的根结点在前序pre中的下标,start和end为当前子树的最左边和最右边的结点在中序in中的下标。用i找到当前子树的根结点root在中序中的下标,然后左边和右边就分别为当前根结点root的左子树和右子树。递归实现~

#include <cstdio>
#include <vector>
#include <stack>
#include <cstring>
using namespace std;
vector<int> pre, in, post;
void postorder(int root, int start, int end) {
	if (start > end) return;
	int i = start;
	while (i < end && in[i] != pre[root]) i++;
	postorder(root + 1, start, i - 1);
	postorder(root + 1 + i - start, i + 1, end);
	post.push_back(pre[root]);
}
int main() {
	int n;
	scanf("%d", &n);
	char str[5];
	stack<int> s;
	for (int i = 0; i < 2 * n; i++) {
		scanf("%s", str);
		if (strlen(str) == 4) {
			int num;
			scanf("%d", &num);
			pre.push_back(num);
			s.push(num);
		} else {
			in.push_back(s.top());
			s.pop();
		}
	}

	 
	postorder(0, 0, n - 1);
	printf("%d", post[0]);
	for (int i = 1; i < n; i++)
		printf(" %d", post[i]);

	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值