PAT A1054. The Dominant Color (20)

原文链接: PAT A1054. The Dominant Color (20)

上一篇: PAT B1044. 火星数字(20)

下一篇: PAT A1071. Speech Patterns (25)

1054. The Dominant Color (20)

https://www.patest.cn/contests/pat-a-practise/1054

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

由于一定存在超过半数的数,采用抵消法,设置ans存放答案,cnt表示ans出现的次数,读入数据t,如果t==ans则cnt++,否则在cnt大于0抵消cnt--,如果cnt为0令ans=t

#include <iostream>
#include <cstdio>
using namespace std;
int main(int argc, char *argv[])
{
	int m,n;
	scanf("%d%d",&n,&m);
	int ans,cnt=0,t;
	//执行n*m-1次 
	for(int i=0;i<m*n;i++){
		scanf("%d",&t);
	 	if(cnt==0)
	 		ans=t;
 		else{
			if(t==ans)
				cnt--;
			else
				cnt++; 		 
	 	}
	}
	printf("%d\n",ans);
	return 0;
}

题目大意:选取主色调,就是M列N行的矩阵里面出现次数多余一半的那个数字。

分析:STL中map的应用。
使用arr[i] = j表示i元素在矩阵中出现了j次,在输入的同时比较arr当前的值是否已经超过半数,如果超过,就直接输出该数字并退出程序。

#include <cstdio>
#include <map>
using namespace std;
int main() {
	int m, n;
	scanf("%d %d", &m, &n);
	map<int, int> arr;
	int half = m * n / 2;
	for(int i = 0; i < n; i++) {
		for(int j = 0; j < m; j++) {
			int temp;
			scanf("%d", &temp);
			arr[temp]++;
			if(arr[temp] > half) {
				printf("%d", temp);
				break;
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值