Description
Given two integers: n and m and n is divisible by 2m, you have to write down the first n natural numbers in the following form. At first take first mintegers and make their sign negative, then take next m integers and make their sign positive, the next m integers should have negative signs and continue this procedure until all the n integers have been assigned a sign. For example, let n be 12 and m be 3. Then we have
-1 -2 -3 +4 +5 +6 -7 -8 -9 +10 +11 +12
If n = 4 and m = 1, then we have
-1 +2 -3 +4
Now your task is to find the summation of the numbers considering their signs.
Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case starts with a line containing two integers: n and m (2 ≤ n ≤ 109, 1 ≤ m). And you can assume that n is divisible by 2*m.
Output
For each case, print the case number and the summation.
Sample Input
2
12 3
4 1
Sample Output
Case 1: 18
Case 2: 2
题意:输入n和m且 n==2m,然后m个数为一组正负交替,像样例一样,然后求和
有公式可以得出:将n除以二可得出有多少段,而m正好是每段的值,
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
long long flag=1;
while(t--)
{
long long n,m;
scanf("%lld%lld",&n,&m);
long long sum;
sum=(n/2)*m;
printf("Case %lld: ",flag++);
printf("%lld\n",sum);
}
return 0;
}