LightOJ 1294:Positive Negative Sign(数学)

18 篇文章 0 订阅
8 篇文章 0 订阅
Description
Given two integers: n and m and n is divisible by 2m, you have to write down the first n natural numbers in the following form. At first take first m integers and make their sign negative, then take next m integers and make their sign positive, the next m integers should have negative signs and continue this procedure until all the n integers have been assigned a sign. For example, let n be 12 and m be 3. Then we have

-1 -2 -3 +4 +5 +6 -7 -8 -9 +10 +11 +12

If n = 4 and m = 1, then we have

-1 +2 -3 +4

Now your task is to find the summation of the numbers considering their signs.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing two integers: n and m (2 ≤ n ≤ 109, 1 ≤ m). And you can assume that n is divisible by 2*m.

Output
For each case, print the case number and the summation.

Sample Input
2
12 3
4 1
Sample Output
Case 1: 18

Case 2: 2

代码:

#include<stdio.h>
int main()
{
	int t;
	while(scanf("%d",&t)!=EOF)
	{
		long long n,m;
		int k=1;
		while(t--)
		{
			scanf("%lld %lld",&n,&m);
			long long sum=n/m;
			long long ans=(sum/2)*m*m;
			printf("Case %d: %lld\n",k++,ans); 
		}
	}
	return 0;
}
题意:有从1到n数,每过m个数就改变一下符号,问最后得到的数。

思路:直接暴力解估计会超时,看规律,每m个数与上m个数相加都为m*m,这时就求有几组m就行了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值