B - Discovering Gold Light oj 1030

B - Discovering Gold
Crawling in process... Crawling failed Time Limit:2000MS    Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Input

Output

Sample Input

Sample Output

Hint

Description


You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect6 sided dice. If you get X in the dice after throwing, you addX to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach theNth position you stop your journey. Now you are given the information about the cave, you have to find out theexpected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line containsN space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to theith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than10-6 will be ignored.

Sample Input

3

1

101

2

10 3

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

这是一个数学期望与dp的入门题,主要是对期望式的理解,这个博客讲的挺好的,看了之后才知道期望的线性的运用;这题简单来说就是找出从第一个点到最后一个点的期望;dp[i]表示从i点到n点的期望

dp[i]=dp[i+1]/6+dp[i+2]/6~~~~+dp[i];

关键是这个式子

;

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
double dp[1005];
int main()
{
    int T;
    cin>>T;
    for(int cas=1;cas<=T;cas++)
    {
        int n;
        cin>>n;
        for(int i=1;i<=n;i++)
            scanf("%lf",&dp[i]);
        for(int i=n-1;i>=1;i--)
        {
            double x=min(n-i,6);
            for(int j=i+1;j<=i+x;j++)
            dp[i]+=dp[j]/x;
        }
        printf("Case %d: %lf\n",cas,dp[1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值