第二十一题 UVa673 Parentheses Balance

116 篇文章 1 订阅

虽然是水题,然而水题教我做人,具体看代码吧

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a) if it is the empty string
(b) if A and B are correct, AB is correct,
© if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your
program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string
a line.
Output
A sequence of ‘Yes’ or ‘No’ on the output file.
Sample Input
3
([])
(([()])))
([()])()
Sample Output
Yes
No
Yes

/*
这么写虽然没什么毛病 但是 WA了之后 我才注意到 对于题目要求的 空串  应该输出 Yes 并不能实现 
#include<iostream>
#include<cstring>
#include<cstdio>
#define Maxn 200000
using namespace std;
char stack[Maxn],s[Maxn];
int main() {
	int T,top;
	scanf("%d",&T);
	while(T--) {
		top = 0;
		scanf("%s",s + 1);
		int len = strlen(s + 1);
		for(int i=1; i<=len; i++) {
			if(s[i] == '(' || s[i] == '[') stack[++top] = s[i];
			else if((s[i] == ']' || s[i] == ')') && top == 0) { top = 1; break; }
			else {
				if(s[i] == ']' && stack[top] == '[') top --;
				if(s[i] == ')' && stack[top] == '(') top --;
			}
		}
		if(top) printf("No");
		else printf("Yes");
		if(T) printf("\n");
	}
	return 0;
} */


#include<iostream>
#include<string>
#include<stack>
using namespace std;
int main() {
    int n;
    cin>>n;
    cin.get();
    while(n--) {
        stack<char> s;
        string str;
        int flag=0;
        getline(cin,str);
        for(int i=0;i<str.size();i++) {
            if(str[i]=='[' || str[i]=='(') s.push(str[i]);
            else if(!s.empty() && s.top() == '(' && str[i]==')') s.pop();
            else if(!s.empty() && s.top() == '[' && str[i]==']') s.pop();
            else flag=1;
        }
        if(!flag && !s.size()) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值