D - Parentheses Balance寒假练习1-D

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a) if it is the empty string
(b) if A and B are correct, AB is correct,
(c) if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your
program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string
a line.
Output
A sequence of ‘Yes’ or ‘No’ on the output file.
Sample Input
3
([])
(([()])))
([()])()
Sample Output
Yes
No
Yes
来源:UVA673
解题思路:匹配串水题,直接判断是不是所有括号都对应,并企鹅只有2中括号,没有其他特殊符号,如果所有括号匹配就输出“YES”,否则输出“NO”。
代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int n,v,l,j,f;
    char s[1010],s1[1010];
    scanf("%d",&n); getchar();
    while(n--)
    {
        v=-1;
        f=0;

        gets(s);

        l=strlen(s);
        if(l==0)
        printf("Yes\n");
        else
        {


        j=0;
        for(int i=0;i<l;i++)
        {
            s1[j]=s[i];
            if(s1[j]==')')
            {
                if(s1[j-1]=='(')
                j-=2;
                else
                break;
            }
            if(s1[j]==']')
            {
                if(s1[j-1]=='[')
                j-=2;
                else
                break;
            }
            j++;
            if(i==l-1&&j==0)
            f=1;

        }
        if(f==1)
        printf("Yes\n");
        else
        printf("No\n");}
    }
    return 0;
}

错误解析:
输入比较坑,要用到gets,因为每一行算一个串,空行也算。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值