第五十九题 UVA821 网页跳跃 Page Hopping

116 篇文章 1 订阅

It was recently reported that, on the average, only 19 clicks are necessary to move from any page on
the World Wide Web to any other page. That is, if the pages on the web are viewed as nodes in a
graph, then the average path length between arbitrary pairs of nodes in the graph is 19.
Given a graph in which all nodes can be
reached from any starting point, your job is to
find the average shortest path length between arbitrary pairs of nodes. For example, consider the
following graph. Note that links are shown as directed edges, since a link from page a to page b
does not imply a link from page b to page a.
The length of the shortest path from node 1
to nodes 2, 3, and 4 is 1,1, and 2 respectively. From node 2 to nodes 1, 3 and 4, the shortest paths
have lengths of 3, 2, and 1. From node 3 to nodes 1, 2, and 4, the shortest paths have lengths of 1, 2,
and 3. Finally, from node 4 to nodes 1, 2, and 3 the shortest paths have lengths of 2, 3, and 1. The
sum of these path lengths is 1 + 1 + 2 + 3 + 2 + 1 + 1 + 2 + 3 + 2 + 3 + 1 = 22. Since there are
12 possible pairs of nodes to consider, we obtain an average path length of 22/12, or 1.833 (accurate
to three fractional digits).
Input
The input data will contain multiple test cases. Each test case will consist of an arbitrary number of
pairs of integers, a and b, each representing a link from a page numbered a to a page numbered b. Page
numbers will always be in the range 1 to 100. The input for each test case will be terminated with a
pair of zeroes, which are not to be treated as page numbers. An additional pair of zeroes will follow
the last test case, effectively representing a test case with no links, which is not to be processed. The
graph will not include self-referential links (that is, there will be no direct link from a node to itself),
and at least one path will exist from each node in the graph to every other node in the graph.
Output
For each test case, determine the average shortest path length between every pair of nodes, accurate to
three fractional digits. Display this length and the test case identifier (theyre numbered sequentially
starting with 1) in a form similar to that shown in the sample output below.
Sample Input
1 2 2 4 1 3 3 1 4 3 0 0
1 2 1 4 4 2 2 7 7 1 0 0
0 0
Sample Output
Case 1: average length between pages = 1.833 clicks
Case 2: average length between pages = 1.750 clicks

题目分析:
Floyd暴力

#include<iostream>
#include<cstring>
#include<cstdio>
#include<map>
#define Maxn 102
using namespace std;
const int INF = 0x3f3f3f3f;
int G[Maxn][Maxn];
map<int,int> mp;
int main() {
	int u,v,tot,x,y,kase = 0;
	while(true) {
		tot = 0; mp.clear();
		scanf("%d %d",&u,&v);
		if(u == 0 && v == 0) break;
		memset(G,INF,sizeof(G));
		if(mp.count(u)) x = mp[u];
		else { mp[u] = ++tot; x = tot; }
		if(mp.count(v)) y = mp[v];
		else { mp[v] = ++tot; y = tot; }
		G[x][y] = 1;
		while(u && v) {
			scanf("%d %d",&u,&v);
			if(u == 0 && v == 0) break;
			if(mp.count(u)) x = mp[u];
			else { mp[u] = ++tot; x = tot; }
			if(mp.count(v)) y = mp[v];
			else { mp[v] = ++tot; y = tot; }
			G[x][y] = 1;
		}
		for(int k=1; k<=tot; k++)
			for(int i=1; i<=tot; i++)
				for(int j=1; j<=tot; j++)
					G[i][j] = min(G[i][j],G[i][k] + G[k][j]);
		double Ans = 0;
		for(int i=1; i<=tot; i++)
			for(int j=1; j<=tot; j++) {
				if(j == i) continue;
				Ans += G[i][j];
			}
		Ans /= tot * (tot - 1) ;
		printf("Case %d: average length between pages = %.3lf clicks\n",++kase,Ans);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值