不写线段树好多年~~ POJ 3468 A Simple Problem with Integers

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 120234 Accepted: 37325
Case Time Limit: 2000MS
Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.
Source

POJ Monthly–2007.11.25, Yang Yi

//不写线段树好多年 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#define MAXN 100005

using namespace std;

typedef long long LL;
struct Seg_Ment_Tree{ int l,r;LL Sum,lazy; } tre[MAXN << 3];

void Build(int u,int l,int r){
    tre[u].l = l,tre[u].r = r,tre[u].lazy = 0,tre[u].Sum = 0;
    if(l == r){ scanf("%lld",&tre[u].Sum); return ; }
    int Mid = l + r >> 1;
    Build(u<<1,l,Mid); Build(u<<1|1,Mid+1,r);
    tre[u].Sum = tre[u << 1].Sum + tre[u << 1 | 1].Sum;
}

inline void Push_Down(int u){
    tre[u<<1].Sum += tre[u].lazy * (tre[u<<1].r - tre[u<<1].l + 1);
    tre[u<<1].lazy += tre[u].lazy;
    tre[u<<1|1].Sum += tre[u].lazy * (tre[u<<1|1].r - tre[u<<1|1].l + 1);
    tre[u<<1|1].lazy += tre[u].lazy;
    tre[u].lazy = 0;
}

void Modify(int u,int l,int r,int val){
    if(l <= tre[u].l && tre[u].r <= r){
        tre[u].Sum += val *(tre[u].r - tre[u].l + 1); tre[u].lazy += val;
        return;
    }
    if(tre[u].lazy) Push_Down(u);
    int Mid = tre[u].l + tre[u].r >> 1;
    if(l > Mid) Modify(u<<1|1,l,r,val);
    else if(r <= Mid) Modify(u<<1,l,r,val);
    else Modify(u<<1,l,Mid,val),Modify(u<<1|1,Mid+1,r,val);
    tre[u].Sum = tre[u<<1].Sum + tre[u<<1|1].Sum;
}

LL Query(int u,int l,int r){
    if(l <= tre[u].l && tre[u].r <= r) return tre[u].Sum;
    if(tre[u].lazy) Push_Down(u);
    int Mid = tre[u].l + tre[u].r >> 1;
    if(r <= Mid) return Query(u<<1,l,r);
    else if(l > Mid) return Query(u<<1|1,l,r);
    else return Query(u<<1,l,Mid) + Query(u<<1|1,Mid+1,r);
}

int main(int argc,char *argv[]){
    int l,r,val,n,m; char c;
    while(scanf("%d%d",&n,&m) != EOF){
        Build(1,1,n);
        for(int i=1; i<=m; ++i){
            getchar(); scanf("%c",&c); scanf("%d%d",&l,&r);
            if(c == 'C') { scanf("%d",&val); Modify(1,l,r,val); }
            else printf("%lld\n",Query(1,l,r));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值