面向对象程序设计上机练习四(变量引用)

Problem Description

将变量的引用作为函数形参,实现2个int型数据交换。

Input

输入2个int型整数。
Output

输出2个整数交换前后的值。

Example Input

88 66

Example Output

88 66
66 88

code

#include <iostream>
using namespace std;

void change(int c, int d)
{
    cout << c << " " << d << endl;
    int t;
    t = c;
    c = d;
    d = t;
    cout << c << " " << d << endl;
}

int main()
{
    int a,b;
    //变量引用
    int &x = a;
    int &y = b;
    cin >> a >> b;
    change(x,y);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值