POJ2.6 1481 Maximum sum

1481:Maximum sum
描述
Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:
t1 t2
d(A) = max{ ∑ai + ∑aj | 1 <= s1 <= t1 < s2 <= t2 <= n }
i=s1 j=s2
Your task is to calculate d(A).
输入
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.
输出
Print exactly one line for each test case. The line should contain the integer d(A).
样例输入
1
10
1 -1 2 2 3 -3 4 -4 5 -5
样例输出
13
提示
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.
Huge input,scanf is recommended.
来源
POJ Contest,Author:Mathematica@ZSU

这题就是指选两个连续子序列使和最大,
首先,以第i个数为终点的最大连续子序列,很好求
DP式为:left[i]=max(left[i-1]+a[i],a[i]);
所以前i个数中的最大连续子序列易得:
leftmax[i]=max(left[i-1],left[i]);
然后我们可以以第i个数前找一个最大子序列,
后面又找一个最大子序列,枚举(i=1~n),找出最大值。

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int G,a[50001],f[50001],maxn=-9999999,mini=-999999999,ans;
int main()
{
    int T,MAX=0;
    scanf("%d",&T);
    for(int i=1;i<=T;i++){
        memset(f,0,sizeof f);
        maxn=-999999999,mini=-999999999,ans=0;
        scanf("%d",&G);
        for(int i=1;i<=G;i++)
        {
            scanf("%d",&a[i]);
            if(f[i-1]>0)f[i]=f[i-1]+a[i];
            else        f[i]=a[i];
        }
        for(int i=G;i>=1;i--)
        {
            ans+=a[i];
            maxn=max(maxn,ans);
            mini=max(mini,maxn+f[i-1]);
            ans=max(ans,0);
        }
        printf("%d\n",mini);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值