1481:Maximum sum

describe

Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:

                 t1     t2 
     d(A) = max{ ∑ai + ∑aj | 1 <= s1 <= t1 < s2 <= t2 <= n }
                i=s1   j=s2

1
2
3
1
2
3
Your task is to calculate d(A).

input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.

output

Print exactly one line for each test case. The line should contain the integer d(A).

sample input

1

10
1 -1 2 2 3 -3 4 -4 5 -5
1
2
3
4
1
2
3
4
sample output

13
1
1
Prompt

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.
这题用两遍dp从左到右算一次,再从右到左算一次。

#include<bits/stdc++.h>
using namespace std;
int t,n,a[100001],s[100001],r[100001],i,j,minn=-999999,r1[100001];
int main()
{
    cin>>t;
    while(t--)
    {
        cin>>n;
        memset(r1,0,sizeof(r1)),memset(a,0,sizeof(a)),memset(s,0,sizeof(s)),memset(r,0,sizeof(r)),minn=-9999999;
        for(i=1;i<=n;i++)  cin>>a[i];
          s[1]=a[1],r[n]=a[n];
          for(i=2;i<=n;i++)
             s[i]=max(s[i-1]+a[i],a[i]);
             for(i=n-1;i>=1;i--)
                    r[i]=max(r[i+1]+a[i],a[i]);
                    r1[n]=r[n];
                     for(i=n-1;i>=1;i--)
                      r1[i]=max(r1[i+1],r[i]);
                    for(i=2;i<=n;i++)
                       minn=max(minn,s[i-1]+r1[i]);
                       cout<<minn<<endl;          

    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值