poj 3040 Allowance

题目
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3643 Accepted: 1464
Description

As a reward for record milk production, Farmer John has decided to start paying Bessie the cow a small weekly allowance. FJ has a set of coins in N (1 <= N <= 20) different denominations, where each denomination of coin evenly divides the next-larger denomination (e.g., 1 cent coins, 5 cent coins, 10 cent coins, and 50 cent coins).Using the given set of coins, he would like to pay Bessie at least some given amount of money C (1 <= C <= 100,000,000) every week.Please help him ompute the maximum number of weeks he can pay Bessie.
Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2..N+1: Each line corresponds to a denomination of coin and contains two integers: the value V (1 <= V <= 100,000,000) of the denomination, and the number of coins B (1 <= B <= 1,000,000) of this denomation in Farmer John’s possession.
    Output

  • Line 1: A single integer that is the number of weeks Farmer John can pay Bessie at least C allowance
    Sample Input

3 6
10 1
1 100
5 120
Sample Output

111
Hint

INPUT DETAILS:
FJ would like to pay Bessie 6 cents per week. He has 100 1-cent coins,120 5-cent coins, and 1 10-cent coin.

OUTPUT DETAILS:
FJ can overpay Bessie with the one 10-cent coin for 1 week, then pay Bessie two 5-cent coins for 10 weeks and then pay Bessie one 1-cent coin and one 5-cent coin for 100 weeks.
首先面额不小于C的硬币属于没办法节约的类型,先发掉。

然后对硬币面额从大到小尽量凑得接近C,允许等于或不足C,但是不能超出C。

接着按硬币面额从小到大凑满C(凑满的意思是允许超出一个最小面值,ps此处的最小面值指的是硬币剩余量不为0的那些硬币中的最小面值),凑满之后得出了最优解,发掉,进入步骤2.

#include<iostream>
#include<algorithm>
#include<limits>
#include<functional>
#include<cstring>
using namespace std;

typedef pair<int ,int >Coin;
Coin coin[20];
int need[20];

int main(){
    int N ,C;
    cin >> N>>C;
    for(int i = 0 ; i<N ; i++){
        cin>>coin[i].first>>coin[i].second;
    }
    int week = 0;
    for(int i= 0; i<N ; i++){
        if(coin[i].first>=C){
            week += coin[i].second;
            coin[i].second = 0;
        }
    }
    sort(coin ,coin+N , greater<Coin>());
    while(true){
        int sum = C;
        memset(need , 0 , sizeof(need));
        for(int i = 0 ; i<N ; i++){
            if(sum >0&& coin[i].second>0){
                int can_use = min(coin[i].second,sum/coin[i].first);
                if(can_use>0){
                    sum-=can_use*coin[i].first;
                    need[i] = can_use;


                }
            }
        }
        for(int i = N-1; i>=0 ; i--){
            if(sum>0&&coin[i].second>0){
                int can_use = min(coin[i].second-need[i] , (sum + coin[i].first - 1) / coin[i].first);
                if(can_use>0){
                    sum-=can_use*coin[i].first;
                    need[i]+=can_use;
                }

            }
        }
        if(sum>0) break;
        int add_up = numeric_limits<int>::max();
        for(int i = 0 ; i<N ; i++){
            if(need[i] ==0) continue;
            add_up = min(add_up , coin[i].second/need[i]);
        }
        week += add_up;
        for(int i = 0 ; i<N ; i++){
            if(need[i] == 0) continue;
            coin[i].second-=add_up*need[i];
        }
    }
    cout << week << endl;


    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值