问题 B: 统计字符串中数字字符个数

题目描述
输入一行字符串(可能包含空格),统计出其中数字字符的个数。
输入
一行字符串,总长度不超过255。
输出
输出字符串中数字字符的个数。
样例输入 Copy
At present, there are more than 20,000 full-time students at ZWU, with a staff of more than 1,000.
样例输出 Copy
9

#include <stdio.h>
#include <string.h>
  
int main(int argc, char *argv[])
{
    char a[1000];int n=0;
    gets(a);
    for(int i=0;i<=strlen(a);i++){
        if(a[i]>='0'&&a[i]<='9') n++;
    }
    printf("%d",n);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值