hdu 1856 More is better

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
Sample Output
4
2

题意:王老师要找尽量多男生帮助他完成实验,只有一间房子,要求最后挑选出的男生之间都是朋友关系,可以说直接或间接。问最多可以挑选出几个男生(最少挑一个)

思路:并查集 + 集合数组,详见代码解析;

#include<stdio.h>
#define maxn 10000000
int pre[maxn],JH[maxn];
int find(int x)//{查,并}的模板; 
{
	int r=x;
	while(r!=pre[r])
		r=pre[r];
	int i=x,j;
	while(i!=r)
	{
		j=pre[i];
		pre[i]=r;
		i=j;
	}
	return r;
}
int main()
{
	int t,p1,p2,i;
	while(scanf("%d",&t)!=EOF)
	{
		for(i=1;i<=maxn;i++)
		{
			pre[i]=i;//初始化树顶; 
			JH[i]=1;//初始化每个集合拥有的元素; 
		}
		while(t--)
		{
			scanf("%d %d",&p1,&p2);
			int fx=find(p1);
			int fy=find(p2);
			if(fx!=fy)
			{
				pre[fy]=fx;//把带有fy的这棵树并入fx这棵树(fy,fx是两棵树的顶部); 
				JH[fx]+=JH[fy];//把fy集合的元素并入fx集合; 
			}
		}
		int tot=0;
		for(i=1;i<=maxn;i++)
		{
			if(tot<JH[i])
				tot=JH[i];//找出最大集合中的元素个数; 
		}
		printf("%d\n",tot);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值