QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370

题意 :t组测试数据,输入n ,然后输入n个数 ,代表连接时每个站点自身的消耗  (适配器价格),然后输入n*n的矩阵  第i行第j列的数代表第i个站点和第j个站点之间路上的花费,连接i , j  两个节点的总花费为两站点自身花费加上路上的花费  求这n个站点连通的最小总花费;

思路:(Kruskal 用习惯了,续更···)计算建立QS网络的最小费用——最小生成树问题。构造连通网时,每条边权值 = 2个QS的适配器价格 + 这2个QS之间网线的价格。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int pre[1000000],v[10010];
struct node
{
	int a;
	int b;
	int c;
}s[1000000];//注意数据范围; 
bool cmp(node x,node y)
{
	return x.c<y.c;
}
int find(int x)
{
	if(pre[x]==-1)
		return x;
	return pre[x]=find(pre[x]);
}
int main()
{
	int t,n,i,j,val,sum;
	scanf("%d",&t);//注意题目的输入格式; 
	while(t--)
	{
		int p=0,num=0,ans=0;
		memset(pre,-1,sizeof(pre));
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&v[i]);
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				scanf("%d",&val);
				if(i!=j)//条件不能是 if(!val),仔细阅读题目; 
				{
					s[p].a=i+1,s[p].b=j+1,s[p].c=val+v[i]+v[j];
					p++;
				}
			}
		}
		sort(s,s+p,cmp);
		for(i=0;i<p && num<n-1;i++)
		{
			int fx=find(s[i].a);
			int fy=find(s[i].b);
			if(fx!=fy)
			{
				pre[fy]=fx;
				num++;
				ans+=s[i].c;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值