QS Network(Kruskal)

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.



Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370

题意:

n地球w-503银河CGB,有一种智能生物命名为QS。通过网络互相qscommunicate。如果两个QS想要连接,他们需要购买两个网络适配器(每个QS的一个)和一段网络电缆。请注意,一个网络适配器只能在一个连接中使用(例如,如果QS要设置四个连接,则需要购买四个适配器)。在通信过程中,QS将其消息发送给所有与之相连的QS,接收消息的QS组将消息广播给所有与之相连的QS,该过程重复直到所有QS接收到消息。每个QS有其最喜欢的品牌的网络适配器和总是买品牌在其所有的连接。QS之间的距离也不同。鉴于网络适配器每个QS的最喜欢的品牌和每对QS之间电缆的价格,你的任务是写一个程序来决定设置一个QS网络最小费用。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
    int u,v,w;
}e[1000100];  //存放边关系,注意数组溢出,大小应该为n*n+1;
int pre[100010]; //存放父节点
int p[1000010];  //存放每个QS最喜欢的适配器价格
int n;
void init(){    //初始化pre
    int i;
    for(i=0;i<=n;i++)
        pre[i]=i;
}
int Find(int x){  //寻找根节点
    int r=x;
    while(r!=pre[r])
        r=pre[r];
    int i=x,j;
    while(i!=r){   //压缩路径
        j=pre[i];
        pre[i]=r;
        i=j;
    }
    return r;
}
int mix(int a,int b){    //如果根节点不同,则结合
    int fa=Find(a),fb=Find(b);
    if(fa!=fb){
        pre[fb]=fa;
        return 1;
    }
    return 0;
}
int cmp(node a,node b){
    return a.w<b.w;
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        memset(e,0,sizeof(e));   //初始化为 0
        memset(pre,0,sizeof(pre));
        memset(p,0,sizeof(p));
        scanf("%d",&n);
        int i;
        for(i=1;i<=n;i++)
            scanf("%d",&p[i]);
        int j;
        int cnt=0;
        for(i=1;i<=n;i++){    //读入每两台适配器直接连通发电线价格
            for(j=1;j<=n;j++){ //由于A-->B 和B--->A 电线价格一样,所以只把左上部分看成边关系
                int m;
                scanf("%d",&m);
                if(i<j){
                    e[cnt].u=i;
                    e[cnt].v=j;
                    e[cnt].w=m+p[i]+p[j];//一个适配器只能用一次,所以加上电线两头适配器的价格
                    cnt++;
                }
            }
        }
        init();
        sort(e,e+cnt,cmp); //费用低的排在前
        int sum=0,countt=0;
        for(i=0;i<cnt;i++){
            if(mix(e[i].u,e[i].v)){   
                sum+=e[i].w;
                countt++;
            }
            if(countt==n-1) break;
        }
        printf("%d\n",sum);
    }
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值