hdu 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47357    Accepted Submission(s): 20927


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 思路:注意这种记忆化搜索,为了不让搜索重复,v数组诞生,但是结束条件有,怎么记录刚刚成环的数字呢,a数组诞生;
记住此类题型,加输出多多理解dfs的递归调用步骤顺序;

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int n;
int a[1010],v[1010];
bool prime(int x)//素数判定; 
{
	if(x==1) return false;
	for(int i=2;i<=sqrt(x);i++)
	{
		if(x%i==0)
			return false;
	}
	return true;
}
void dfs(int x,int y)
{
	if(y==n)//找准递归结束条件;
	{
		if(prime(a[n-1]+1))//首尾和也要为素数; 
		{
			for(int i=0;i<n;i++)
			{
				if(i>=1)
					printf(" ");
				printf("%d",a[i]);
			}
			printf("\n");
		}
		return ;
	}
	else
	{
		for(int i=2;i<=n;i++)
		{
			if(prime(i+x) && !v[i])
			{
				a[y]=i;
				v[i]=1;
				dfs(i,y+1);
				v[i]=0;
			}
		}
	}
}
int main()
{
	int p=1;
	while(scanf("%d",&n)!=EOF)
	{
		memset(v,0,sizeof(v));
		memset(a,0,sizeof(a));//记录能够成环的数字; 
		printf("Case %d:\n",p++);
		v[1]=1,a[0]=1;//初始起始1; 
		dfs(1,1);
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值