hdoj4135 容斥原理模板

Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.

思路:模板题,求出b-(a-1)中与n互质的即可,熟练模板;

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#define max_n 10010
typedef long long LL;
using namespace std;

LL p[max_n],k;//p保存质因子,int型n不会超过10个,k代表记录质因子个数 

void getp(LL n)//求出n的质因子 
{
	k=0;
	for(int i=2;i*i<=n;i++)
	{
		if(n%i==0)
		{
			p[k++]=i; //保存质因子
			while(n%i==0)
				n/=i;
		}
	}
	if(n>1) p[k++]=n; //本身是质数 
}

LL nop(LL m) //求出区间[1,m]里面有多少个数与n不互质
{
	LL top=0,sum=0;
	LL que[max_n];
	que[top++]=-1;  //队列数组保存n所有质因子任意不相同组合的乘积
	for(int i=0;i<k;i++)
	{
		LL t=top;
		for(int j=0;j<t;j++)
			que[top++]=que[j]*p[i]*(-1); //奇加偶减
	}
	for(int i=1;i<top;i++)
		sum+=m/que[i]; //统计个数 
	return sum; //求区间[1,m]内有多少个数与n互质
}

int main()
{
	LL n,t,a,b,k=1;
	scanf("%lld",&t);
	while(t--)
	{
		scanf("%lld %lld %lld",&a,&b,&n);
		getp(n);  //互质的对象 
		printf("Case #%lld: %lld\n",k++,b-nop(b)-(a-1-nop(a-1)));
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值