hdoj2841 容斥原理+思维

Visible Trees
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3057    Accepted Submission(s): 1352



Problem Description
There are many trees forming a m * n grid, the grid starts from (1,1). Farmer Sherlock is standing at (0,0) point. He wonders how many trees he can see.

If two trees and Sherlock are in one line, Farmer Sherlock can only see the tree nearest to him.
 

Input
The first line contains one integer t, represents the number of test cases. Then there are multiple test cases. For each test case there is one line containing two integers m and n(1 ≤ m, n ≤ 100000)
 

Output
For each test case output one line represents the number of trees Farmer Sherlock can see.
 

Sample Input
  
  
2 1 1 2 3
 

Sample Output
  
  
1 5
 

题目翻译:给你一个(m,n)的矩阵,每个点上有一颗树,你站在(0,0)点看矩阵,前面的树会挡着后面的树,互质不会被挡,问你此时一共可以看到多少树!
思路:由于是站在(0,0),因此此时被挡的那棵树(X,Y)和挡它的那棵树(x,y)有一些关系,此时和(0,0)三点共线,因此X / x == Y / y;
因此(X,Y)必有公约数,因此点任意一点(A,B)只要A,B有约数,则一定看不到,反之,A,B互质则一定可以看到,因此问题转化为求图中的互质点对;(容斥模板

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define max_n 10010
typedef long long LL;
using namespace std;

int p[max_n],k;//p保存质因子,int型n不会超过10个,k代表记录质因子个数 

void getp(int n)//求出n的质因子 
{
	k=0;
	for(int i=2;i*i<=n;i++)
	{
		if(n%i==0)
		{
			p[k++]=i; //保存质因子
			while(n%i==0)
				n/=i;
		}
	}
	if(n>1) p[k++]=n; //本身是质数 
}

int nop(int m) //求出区间[1,m]里面有多少个数与n不互质
{
	int top=0,sum=0;
	int que[max_n];
	que[top++]=-1;  //队列数组保存n所有质因子任意不相同组合的乘积
	for(int i=0;i<k;i++)
	{
		int t=top;
		for(int j=0;j<t;j++)
			que[top++]=que[j]*p[i]*(-1); //奇加偶减
	}
	for(int i=1;i<top;i++)
		sum+=m/que[i]; //统计个数 
	return sum; //求区间[1,m]内有多少个数与n互质
}

int main()
{
	int n,m,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&n,&m);
		LL ans=n;
		for(int i=2;i<=m;i++)
		{
			getp(i);
			ans+=n-nop(n);
		}
		printf("%lld\n",ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值