POJ 3254 Corn Fields【状压dp】

POJ 3254
Description
Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.
Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.
Input
Line 1: Two space-separated integers: M and N
Lines 2…M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output
Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0
Sample Output
9
Hint
Number the squares as follows:
1 2 3
4
There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
Source
USACO 2006 November Gold

分析:
$dp[i][j]:第i种状态在第j行的方案总数,dp[p][i]+=dp[j][i−1]; $
$vis[i]:表示第i种的状态; $
$res[i]:预处理的可填格子,二进制表示; $
把满足的状态先预处理状压出来,把网格可填的位置用二进制表示,然后把这些状态按行填进去,和可填的状态再进行与运算。初始化第一行,然后暴力第i行,通过枚举第i−1行状态,进行状态转移.

#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
#define met(s) memset(s, 0, sizeof(s))
#define rep(i, a, b) for(int i = a; i <= b; ++i)
template <class T> inline void scan_d(T &ret) {
char c; ret = 0;
while ((c = getchar()) < '0' || c > '9');
while (c >= '0' && c <= '9') {
ret = ret * 10 + (c - '0'), c = getchar();}}
typedef long long LL;
typedef unsigned long long ull;
typedef pair<int, int> pii;
const int INF = 0x3f3f3f3f;
const int mod = 1e8;
const int MAXN = 25;
int a[MAXN], b[MAXN];
int dp[15][1 << 13];

int main() {
//	freopen("in.txt", "r", stdin);
//	freopen("out.txt", "w", stdout);
	int n, m;
	scanf("%d %d", &n, &m);
	for(int i = 1; i <= n; ++i) {
		int ans = 0, k;
		for(int j = 1; j <= m; ++j) {
			scanf("%d", &k);
			ans = (ans << 1) + k;
		}
		a[i] = ans;
	}
	int sum = 0;
	for(int i = 0; i < (1 << m); ++i) {
	//	printf("## %d %d %d\n", (i & (i << 1)), (i & a[1]), i);
		if((i & (i << 1)) || ((i & a[1]) != i)) continue;
		dp[1][i] = 1;
	//	printf("%d\n", i);
	}
	for(int i = 2; i <= n; ++i) {
		for(int j = 0; j < (1 << m); ++j) {
			if(j & (j << 1) || (j & a[i]) != j) continue;
			for(int p = 0; p < (1 << m); ++p) {
				if(p & (p << 1) || (p & a[i - 1]) != p || p & j) continue;
				dp[i][j] += dp[i - 1][p];
				dp[i][j] %= mod;
			}
		}
	}
	for(int i = 0; i < (1 << m); ++i) {
		sum += dp[n][i];
		sum %= mod;
	}
	printf("%d\n", sum);
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值