poj3254 Corn Fields 状压dp

Language:
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6539 Accepted: 3482

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source


题意:给定一个m*n的0、1矩阵,1表示可放置,0表示不可放置,问有多少种放置方法而相邻可放置位置不能同时放。

思路:很明显的状压dp,由于相邻可放置位置不能同时放,所以首先将一行1<<n种状态中的可行状态存储在s数组中,然后根据每层与其上一层的关系地推。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=15;
const int M=600+100;
const int mod=1000000000;
int n,m,cnt;
int cur[M],s[M],dp[MAXN][M];
void init()
{
    cnt=0;
    memset(cur,0,sizeof(cur));
    memset(dp,0,sizeof(dp));
    for(int i=0;i<(1<<n);i++)
        if(i&(i<<1))
           continue;
        else
            s[++cnt]=i;   //
}
inline bool ok(int x,int k)
{
    if(x & cur[k])
        return 0;
    return 1;
}
int main()
{
    //freopen("text.txt","r",stdin);
    while(~scanf("%d%d",&m,&n))
    {
        init();
        for(int i=1;i<=m;i++)
        {
            cur[i]=0;
            for(int j=1;j<=n;j++)
            {
                int x;
                scanf("%d",&x);
                if(!x)cur[i]+=(1<<(n-j));
            }
        }
        for(int i=1;i<=cnt;i++)
            if(ok(s[i],1))
                dp[1][i]=1;
        for(int i=2;i<=m;i++)
            for(int k=1;k<=cnt;k++)
            {
                if(!ok(s[k],i))
                    continue;
                for(int j=1;j<=cnt;j++)
                {
                    if(!ok(s[j],i-1))
                        continue;
                    if(s[k] & s[j])
                        continue;
                    dp[i][k]=(dp[i][k]+dp[i-1][j])%mod;
                }
            }
        int ans=0;
        for(int i=1;i<=cnt;i++)
            ans=(ans+dp[m][i])%mod;
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值