String HDU - 4821

Given a string S and two integers L and M, we consider a substring of S as “recoverable” if and only if
  (i) It is of length M*L;
  (ii) It can be constructed by concatenating M “diversified” substrings of S, where each of these substrings has length L; two strings are considered as “diversified” if they don’t have the same character for every position.

Two substrings of S are considered as “different” if they are cut from different part of S. For example, string "aa" has 3 different substrings "aa", "a" and "a".

Your task is to calculate the number of different “recoverable” substrings of S.

Input

The input contains multiple test cases, proceeding to the End of File.

The first line of each test case has two space-separated integers M and L.

The second ine of each test case has a string S, which consists of only lowercase letters.

The length of S is not larger than 10^5, and 1 ≤ M * L ≤ the length of S.

Output

For each test case, output the answer in a single line.

Sample Input

3 3
abcabcbcaabc

Sample Output

2

 

1.那个base值得是 素数,不是很理解原理

2.ULL 自然溢出,不用担心

#include<bits/stdc++.h>
using namespace std;

typedef unsigned long long ULL;
typedef long long LL;
#define rep(i,a,b) for(int i=a;i<b;++i)

const int N=1e5+10;
char str[N];
unordered_map<ULL,int> has;

ULL dig=31;
ULL base[N],sum[N];
ULL val[N];

int main(){
    //freopen("123.txt","r",stdin);
    //freopen("789.txt","w",stdout);
    base[0]=1;
    rep(i,1,N)base[i]=base[i-1]*dig;//自然溢出

    int m,L;
    while(scanf("%d %d",&m,&L)==2){
        scanf("%s",str+1);
        int len=strlen(str+1);
        LL ans=0;

        for(int i=1;i<=len;i++)sum[i]=(sum[i-1]*dig+str[i]-'a');

        for(int j=0;j<L;j++){
            has.clear();
            int l=0,r=0;
            for(int i=1+j;i+L-1<=len;i+=L){
                ULL res=(sum[i+L-1]-sum[i-1]*base[L]);
                val[++r]=res;
                if(has[res]){
                    while(l<r){
                        has[val[++l]]--;
                        if(val[l]==res)break;
                    }
                    has[res]++;
                }else{
                    has[res]++;
                }

                if(r-l>=m) ans++;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值