A Simple Math Problem HDU - 5974

Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
Sample Input
6 8
798 10780

Sample Output

No Solution
308 490

输入两个整数a,b,知否可以找到两个整数x,y.使其满足x+y=a,lcm(x,y)=b 如果找不到输出No Solution 否则输出x y(x<=y)

gcd(x,y)=gcd(a,b);

可以记住一个结论:a和b两个数,可以分解成x,y使得x+y=a,x和y的最小公倍数是b,(lcm(x,y)=b, 那么有gcd(a,b)=gcd(x,y);

#include <iostream>
#include <math.h>
using namespace std;
int gcd(int x,int y)
{
    if(y==0)
        return x;
    else
        return gcd(y,x%y);
}
int main()
{
    int a,b,temp,k,d;
    while(cin>>a>>b)
    {
        temp=gcd(a,b);
        b*=temp;
        k=a*a-4*b;
        d=sqrt(k);
        if(k<0||d*d!=k||(a+d)%2!=0)
        {
            cout<<"No Solution"<<endl;
            continue;
        }
        d=(a+d)/2;
        k=a-d;
        if(d<=k)
            cout<<d<<' '<<k<<endl;
        else
            cout<<k<<' '<<d<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值