PAT 1131 Subway Map

参考博客:https://www.liuchuo.net/archives/3850

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.

subwaymap.jpg

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 100), the number of subway lines. Then N lines follow, with the i-th (i=1,⋯,N) line describes the i-th subway line in the format:

M S[1] S[2] ... S[M]

where M (≤ 100) is the number of stops, and S[i]'s (i=1,⋯,M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order -- that is, the train travels between S[i] and S[i+1] (i=1,⋯,M−1) without any stop.

Note: It is possible to have loops, but not self-loop (no train starts from S and stops at S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called "transfer stations"), no station can be the conjunction of more than 5 lines.

After the description of the subway, another positive integer K (≤ 10) is given. Then K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.

The following figure shows the sample map.

samplemap.jpg

Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.

Output Specification:

For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:

Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
......

where Xi's are the line numbers and Si's are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.

If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.

Sample Input:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001

Sample Output:

2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.

解题思路:由于地铁地图每个站点与多个站点相连,但是每两个站点之间的一段线路是唯一属于某一条线路的。如果没有内存限制可以使用邻接矩阵保存相邻站点之间的线路号。由于站点的编号为4位,所以可以使用map<int,int>  ,first 高4位与低4位分别存储线路两端的站点编号,即staa*10000+stab;或者使用string 存储站点编号,map<string,int> , first 为两个相连站点的字符串拼接。使用DFS 从起点遍历。设置全局变量保存当前获得的最短路径以及最少换乘次数。

题目中有三个测试点需要按照要求加上前导0使得输出站点的编号为4位。


#include <iostream>
#include <unordered_map>
#include <vector>
#include <climits>
#include <string>
#include <iomanip>
using namespace std;

unordered_map<int, int> staline; // path between two station line
unordered_map<int, vector<int>> adjs;
unordered_map<int, bool> vis;
int shortest = INT_MAX, min_line = INT_MAX;
vector<int> ans, tmpans;

void dfs(int sta, int aim,int presta, int sta_cnt, int line_cnt) {
	if (vis[sta])
		return;
	vis[sta] = true;
	int preline = staline[presta * 10000 + sta];
	//cout << "DEBUG:" << "preline is #" << preline << ", sta=" << sta << ", aim is" << aim
	//	<< ", presta=" << presta << ",sta_cnt=" << sta_cnt
	//	<< ", line_cnt=" << line_cnt << endl;
	sta_cnt++;
	tmpans.push_back(sta);
	if (sta == aim) {
		if (sta_cnt < shortest || (sta_cnt == shortest && line_cnt < min_line)) {
			ans.assign(tmpans.begin(), tmpans.end());
			shortest = sta_cnt;
			min_line = line_cnt;
			vis[sta] = false;
			tmpans.pop_back();
		}
		else {
			tmpans.pop_back();
			vis[sta] = false;
		}
	}
	else {
		for (int next : adjs[sta]) {
			if (!vis[next]) {
				int nextline = staline[next * 10000 + sta];
				//cout << "DEBUG[in next test]:" << "preline is #" << preline << ", sta=" << sta << ", aim is" << aim
				//	<< ", presta=" << presta << ",sta_cnt=" << sta_cnt
				//	<< ", line_cnt=" << line_cnt << endl;
				if (nextline != preline)
					dfs(next, aim, sta, sta_cnt, line_cnt + 1);
				else
					dfs(next, aim, sta, sta_cnt, line_cnt);
			}
		}
		tmpans.pop_back();
		vis[sta] = false;
	}

}

int main()
{
	int n;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		int m;
		cin >> m;
		int presta = -1;
		for (int j = 0; j < m; ++j) {
			int sta;
			cin >> sta;
			if (presta == -1) {
				presta = sta;
			}
			else {
				staline[presta * 10000 + sta] = i + 1;
				staline[sta * 10000 + presta] = i + 1;
				adjs[presta].push_back(sta);
				adjs[sta].push_back(presta);
				presta = sta;
			}
		}
	}
	//cout << "DEBUG:\n";
	//for (auto ele : adjs) {
	//	for (auto s : ele.second)
	//		cout << ele.first << "---" << s << endl;
	//}
	int k;
	cin >> k;
	while (k--) {
		int l, r;
		cin >> l >> r;
		tmpans.clear();
		shortest = INT_MAX;
		min_line = INT_MAX;
		vis.clear();
		for (int next : adjs[l]) {
			vis[l] = true;
			tmpans.clear();
			tmpans.push_back(l);
			dfs(next, r, l, 1, 1);
		}

		/*for (int sta : ans)
			cout << sta << " ";
		cout << endl;*/
		cout << ans.size()-1 << endl;
		int i = 0, j = 1;
		int line = staline[ans[i] * 10000 + ans[j]];
		while (j < ans.size()) {
			while (j < ans.size() && staline[ans[j] * 10000 + ans[j - 1]] == line)
				j++;
			j--;
			//cout << setw(4) << setfill('0') << "Take Line#" << line
			//	<< " from "<< ans[i] << " to "<< ans[j] << "." << endl;
			printf("Take Line#%d from %04d to %04d.\n",line,ans[i],ans[j]);
			int t = 2;
			i = j;
			j = i + 1;
			if (j < ans.size())
				line = staline[ans[i] * 10000 + ans[j]];
		}
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值