HDU - 1331 Function Run Fun 记忆化搜索

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result. 
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1 
Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


一个超级水的记忆化搜索,然而,然而。。。。。。。。

我WA了几次,一脸懵逼,请注意第一个条件和第二个条件的先后顺序,原本以为一样手贱先写了大于20的判断,后来发现不一样,比如说w(-1,50,50),而题目的 意思是想让你先按照小于0,天天debug


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int d[21][21][21];
int w(int a,int b,int c){
	if(a<=0||b<=0||c<=0){
		return 1;
	}
	if(a>20||b>20||c>20){
		if(d[20][20][20]!=-1){
			return d[20][20][20];
		}else{
			d[20][20][20] = w(20,20,20);
			return d[20][20][20];
		}
	}
	if(a<b&&b<c){
		if(d[a][b][c-1]==-1){
			d[a][b][c-1] = w(a,b,c-1);
		}
		if(d[a][b-1][c-1]==-1){
			d[a][b-1][c-1] = w(a,b-1,c-1);
		}
		if(d[a][b-1][c]==-1){
			d[a][b-1][c] = w(a,b-1,c);
		}
		return d[a][b][c-1]+d[a][b-1][c-1]-d[a][b-1][c];
	}else{
		if(d[a-1][b][c]==-1){
			d[a-1][b][c] = w(a-1, b, c);
		}
		if(d[a-1][b-1][c]==-1){
			d[a-1][b-1][c] = w(a-1, b-1, c);
		}
		if(d[a-1][b][c-1]==-1){
			d[a-1][b][c-1] = w(a-1, b, c-1);
		}
		if(d[a-1][b-1][c-1]==-1){
			d[a-1][b-1][c-1] = w(a-1, b-1, c-1);
		}
		return d[a-1][b][c] + d[a-1][b-1][c] + d[a-1][b][c-1] - d[a-1][b-1][c-1]; 
	}
}
int main(){
	int a,b,c;
	memset(d,-1,sizeof(d)); 
	while(scanf("%d%d%d",&a,&b,&c)&&(a!=-1||b!=-1||c!=-1)){
		printf("w(%d, %d, %d) = %d\n",a,b,c,w(a,b,c));
	}
} 









  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_我走路带风

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值