1056 Mice and Rice (25 分)C语言——ceil()

1056 Mice and Rice (25 分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NPN_PN​P​​ programmers. Then every NGN_GN​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NGN_GN​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NPN_PN​P​​ and NGN_GN​G​​ (≤1000\le 1000≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NGN_GN​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NPN_PN​P​​ distinct non-negative numbers WiW_iW​i​​ (i=0,⋯,NP−1i=0,\cdots ,N_P -1i=0,⋯,N​P​​−1) where each WiW_iW​i​​ is the weight of the iii-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,NP−10,\cdots ,N_P -10,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to NP−1N_P -1N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The iii-th number is the rank of the iii-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

分析

the sake of simplicity 简单的目的

initial 最初的

permutation 排列 置换

math.h    ceil()向上取整  floor()向下取整

代码

#include<stdio.h>
#include<math.h>
#define Max 1005
struct{
    int weight,rank;
}player[Max];
int main(){
    int NP,NG,order[Max];
    int groupnum,playernum,max;
    int i,j,p1,p2;
    scanf("%d %d",&NP,&NG);
    for(i=0;i<NP;i++) scanf("%d",&player[i].weight);
    for(i=0;i<NP;i++)  scanf("%d",&order[i]);
    //contest
    playernum=NP;
    while(1){
        /// one turn start
        groupnum=ceil((double)playernum/NG);
        for(i=0;i<groupnum;i++){
            ///one group contest start
            max=i*NG;
            for(j=i*NG+1;j<playernum && j<(i+1)*NG;j++){
                p1=order[max];p2=order[j];
                if(player[p2].weight>player[p1].weight){
                    player[p1].rank=groupnum+1;
                    max=j;
                }else player[p2].rank=groupnum+1;
            }
            ///one group contest end
            order[i]=order[max];
        }
        ///one turn end
        if(groupnum==1)break;
        playernum=groupnum;
    }
    ///first winner
    player[ order[max] ].rank=1;
    //output
    printf("%d",player[0].rank);
    for(i=1;i<NP;i++)  printf(" %d",player[i].rank);
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值