A1056 Mice and Rice (25分)_C语言_队列的应用

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​Gmice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains NPdistinct non-negative numbers Wi(i=0,⋯,NP−1) where each W​iis the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
const int maxn=1010;
struct mouse
{
	int weight;
	int R;
}mouse[maxn];
int main()
{
	int np,ng,order;
	cin>>np>>ng;
	for(int i=0;i<np;i++)
	{
		cin>>mouse[i].weight ;
	}
	queue<int> q;
	for(int i=0;i<np;i++)
	{
		cin>>order;//把样例中的序号输入并放到队列里
		q.push(order);
	}
	int temp=np,group;
	while(q.size()!=1)
	{
		if(temp%ng==0) group=temp/ng;
		else group=temp/ng+1;//如果不能整除,则多加一组
	
	for(int i=0;i<group;i++)
	{
		int k=q.front();//k为整个组最大重量的老鼠,先初始化为第一个
		for(int j=0;j<ng;j++)
		{
			if(i*ng+j>=temp) break;//如果已经超过了现存的老鼠数,这里为了避免不能整除老鼠的情况时出现的错误
			int front=q.front();//front为队首老鼠的编号
			if(mouse[front].weight >mouse[k].weight )
				k=front;
			mouse[front].R=group+1;//该轮所有的老鼠都赋值为组数+1,晋级的老鼠也会被赋值,但是在下一晋级赛中会被赋新的值
			q.pop();//把当前的老鼠出队
		}
		q.push(k);//一个组过后把晋级的老鼠放入队列后
	}
	temp=group;//这一轮比完进行下一轮,有几个组就有几个老鼠晋级
	}
	mouse[q.front()].R =1;//把最后一只老鼠的排名赋值为1
	//输出所有老鼠信息
	for(int i=0;i<np;i++)
	{
		cout<<mouse[i].R ;
		if(i<np-1) cout<<" ";
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值