HDU 3070 Fibonacci

Fibonacci

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 15   Accepted Submission(s) : 6
Problem Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

 

Input
<span lang="en-us"><p>The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ <i>n</i> ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.</p></span>
 

Output
<span lang="en-us"><p>For each test case, print the last four digits of <i>F<sub>n</sub></i>. If the last four digits of <i>F<sub>n</sub></i> are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print <i>F<sub>n</sub></i> mod 10000).</p></span>
 

Sample Input
  
  
0 9 999999999 1000000000 -1
 

Sample Output
  
  
0 34 626 6875
 

Source
PKU
 
快速幂模板:
long long modexp(long long a, long long b, int mod)  
{  
    long long res=1;  
    while(b>0)  
    {  
        //a=a%mod;(有时候n的值太大了会超出long long的储存,所以要先取余)  
        if(b&1)//&位运算:判断二进制最后一位是0还是1,&的运算规则为前后都是1的时候才是1,奇数偶数判断;  
            res=res*a%mod;  
        b=b>>1;//相当于除以2;  
        a=a*a%mod;  
    }  
    return res;  
}  
代码:
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
struct fast_mod
{
    int t[2][2];
};
fast_mod matrixmul(fast_mod a,fast_mod b)
{
    int i,j,k;
    fast_mod c;
    for(i=0; i<2; i++)
    {
        for(j=0; j<2; j++)
        {
            c.t[i][j]=0;
            for(k=0; k<2; k++)
            {
                c.t[i][j]+=(a.t[i][k]*b.t[k][j])%10000;
            }
        }
    }
    return c;
}
int main()
{
    int n,i;
    while(scanf("%d",&n),n!=-1)
    {
        if(!n)
        {
            printf("0\n");
            continue;
        }
        fast_mod s;
        s.t[0][0]=s.t[0][1]=s.t[1][0]=1;
        s.t[1][1]=0;
        fast_mod ans;
        memset(ans.t,0,sizeof(ans.t));
        for(i=0; i<2; i++)
        {
            ans.t[i][i]=1;
        }
        while(n)
        {
            if(n&1)
                ans=matrixmul(ans,s);
            n=n>>1;
            s=matrixmul(s,s);
        }
        cout<<ans.t[0][1]%10000<<endl;
    }

}




深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值