PAT 1136 A Delayed Palindrome python解法

该博客介绍了一个关于计算延迟回文数的问题,即给定一个正整数,通过反复将其与反转数相加直到得到回文数。文章提供了一个Python解法,并给出了样例输入和输出。解题思路包括定义判断回文数的函数和执行加法操作的函数,循环最多10次,若未找到回文数则在10次后输出特定信息。
摘要由CSDN通过智能技术生成

1136 A Delayed Palindrome (20 分)
Consider a positive integer N written in standard notation with k+1 digits a​i​​ as aki​​ ⋯a​1​​ a​0​​ with 0 ≤ a​i​​ < 10 for all i and ak​​ > 0. Then N is palindromic if and only if a​i​​ = ak-1​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:
Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:
For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

题意:给出一个数x,求这个数加上它的反转数,判断相加结果是否为回文数,是则输出x is a palindromic number.否则继续将结果加上结果的反转进行判断,如果10次之后还没有获得回文数,则输出Not found in 10 iterations.

解题思路:定义两个函数,一个函数palindromic(n)判断n是否是回文数,另一个函数f_sum(a)按照题意进行求和操作,循环10次,每次判断n是否为回文数,是则输出相应结果并跳出循环,不是则继续进行求和,10次循环完成后输出相应结果。

n = input()
def palindromic(n):
    if n[::-1] == n:
        print(n +' is a palindromic number.')
        return True
    else:
        return False
def f_sum(a):
    b = int(a[::-1])
    a = int(a)
    print('%d + %d = %d'%(a,b,a+b))
    return str(a+b)
for i in range(10):
    if palindromic(n):
        break
    n = f_sum(n)
else:
    print('Not found in 10 iterations.')
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

D_ry

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值