山东省第八届ACM省赛 J 题(company)

Problem Description

There are n kinds of goods in the company, with each of them has a inventory of  and direct unit benefit . Now you find due to price changes, for any goods sold on day i, if its direct benefit is val, the total benefit would be i⋅val.
Beginning from the first day, you can and must sell only one good per day until you can't or don't want to do so. If you are allowed to leave some goods unsold, what's the max total benefit you can get in the end?
Input

The first line contains an integers n(1≤n≤1000).
The second line contains n integers val1,val2,..,valn(−100≤.≤100).
The third line contains n integers cnt1,cnt2,..,cntn(1≤≤100).
Output

Output an integer in a single line, indicating the max total benefit.
Example Input

4
-1 -100 5 6
1 1 1 2

Example Output

51

Hint

sell goods whose price with order as -1, 5, 6, 6, the total benefit would be -1*1 + 5*2 + 6*3 + 6*4 = 51.


题意:商店买东西,有n种商品,每种商品卖出去以后得到的价值是v,每种商品有c件,第i天卖出v价值的商品,得到的价值是i*v,时间是从第一天开始,每天只能卖一件,对于每件商品你可以选择卖或者不卖;


思路:把每件商品都存到一个数组里,排序,找到第一个不是负数的数,记录位置,然后把这个位置之后的(包括它自己)按顺序全卖,然后把这个位置往前移一位,再进行,记录得到的最大的价值;


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define maxn 100010
#define INF 0x3f3f3f3f
using namespace std;
int d[maxn];
int n,v[1010],c[1010];
long long sum,MAX;
int main()
{
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&v[i]);
    }
    for(int i=0; i<n; i++)
    {
        scanf("%d",&c[i]);
    }
    int ii=1;
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<c[i]; j++)
        {
            d[ii++]=v[i];
        }
    }
    sort(d+1,d+ii);
    d[0]=-1;  //这个地方是为了避免全是正数或者全是负数的情况;
    d[ii]=1;
    int xx=0;
    for(int i=1; i<ii; i++) //找的第一个不是负数的数;
    {
        if(d[i]>=0&&d[i-1]<0)
        {
            xx=i;
            break;
        }
    }
    MAX=-INF;
    for(int i=0; i<xx; i++) //挨个的往前取,并把最大的保存;
    {
        int day=1;
        sum=0;
        for(int j=xx-i; j<ii; j++)
        {
            sum+=day*d[j];
            day++;
        }
        if(MAX<sum) MAX=sum;
    }
    cout<<MAX<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值