Cube Stacking(POJ-1988)

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2


题意:搬箱子和架箱子,如果箱子上面有箱子,则再不打乱顺序的条件下把整体搬过去


思路:在并查集的基础上加一个旧根的深度的数组,旧根的深度等于新根上一次的节点数,最后输出的时候,查根,减去改节点的深度,再减去本身


#include<iostream>
#include<cstdio>
using namespace std;
int a[30005];
int d[30005];
int f[30005];
int find(int x)
{
   int temp;
	if(x == a[x])
		return x;
	temp = a[x];
	a[x] = find(temp);
	d[x] += d[temp];
	return a[x];
}
int main()
{
    int p;
    int x,y;
    char s;
    char c;
    scanf("%d",&p);
    s=getchar();
    for(int i=0;i<=30000;i++){
        a[i]=i;
        d[i]=0;
        f[i]=1;
    }
    for(int i=0;i<p;i++){
        scanf("%c",&c);
        if(c=='M'){
            scanf("%d%d",&x,&y);
            s=getchar();
            x=find(x);
            y=find(y);
            if(x!=y){
                a[y]=x;
                d[y]=f[x];
                f[x]+=f[y];
            }
        }
        if(c=='C'){
            scanf("%d",&x);
            s=getchar();
            printf("%d\n",f[find(x)]-d[x]-1);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值