hdu-3555 Bomb

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 21975    Accepted Submission(s): 8253


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
 
 
3 1 50 500
 

Sample Output
 
 
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

题意:求1 ~ n有多少个数字里含有49.

题解:数位dp,从上往下搜索即可。跟不要62没什么本质差别。

AC代码

#include <stdio.h>
#include <iostream>
#include <string>
#include <queue>
#include <map>
#include <vector>
#include <algorithm>
#include <string.h>
#include <cmath>
typedef unsigned long long ll;
 
using namespace std;

const int maxn = 22;

struct node{
	ll sum0, sum9;
}dp[22];
ll a[maxn];

node dfs(int len, int limit, int m){
	node t1, t2, ans;
	if(dp[len - 1].sum0 + dp[len - 1].sum9)
		t1 = dp[len - 1];
	else
		t1 = dfs(len - 1, 0, 0);
	ans.sum0 = ans.sum9 = 0;
	if(!limit){
		ans.sum0 = (ll)8 * (t1.sum0 + t1.sum9) + t1.sum0;
		ans.sum9 = (t1.sum0 + t1.sum9);
		dp[len] = ans;
	}
	else{
		if(len - 1 == 0)
			t2 = dp[0];
		else
			t2 = dfs(len - 1, 1, 0);
		if(a[len] == (ll)9){
			ans.sum0 = (ll)(8 - m) * (t1.sum0 + t1.sum9) + t1.sum0;
			ans.sum9 = (t2.sum0 + t2.sum9);
		}
		else if(a[len] > 4)
			ans.sum0 = (ll)(a[len] - (ll)1 - m) * (t1.sum0 + t1.sum9) + t1.sum0 + (t2.sum0 + t2.sum9);
		else if(a[len] == 4)
			ans.sum0 = (ll)(a[len] - m) * (t1.sum0 + t1.sum9) + t2.sum0;
		else
			ans.sum0 = (ll)(a[len] - m) * (t1.sum0 + t1.sum9) + (t2.sum0 + t2.sum9);
	}
	return ans;
}

ll solve(ll n){
	ll temp = n;
	int pos = 0;
	while(n){
		a[++pos] = (n % 10);
		n /= 10;
	}
	node ans = dfs(pos, 1, 1);
	for(int i = 1; i <= pos; i++)
		a[i] = 9;
	for(int i = pos - 1; i >= 1; i--){
		node ans1 = dfs(i, 1, 1);
		ans.sum0 += ans1.sum0;
		ans.sum9 += ans1.sum9;
	}
	return (temp - ans.sum0 - ans.sum9);
}

int main(){
	for(int i = 0; i < maxn; i++)
		dp[i].sum0 = dp[i].sum9 = 0;
	dp[0].sum0 = 1;
	int t;
	ll n;
	scanf("%d", &t);
	while(t--){
		scanf("%llu", &n);
		printf("%llu\n", solve(n));
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值