PAT甲级A1009 】Product of Polynomials (25分)(c++)

1009 Product of Polynomials (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​​ a​N​1​​ N​2​​ a​N​2​​ ​​ … N​K​​ a​N​K
​​ ​​
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​ <⋯<N​2​​ <N​1​​ ≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题意:

多项式相乘,输出保留一位小数。

思路:

建立哈希表记录,最多指数为1000,相乘为2000,所以开2001个单位。用a1a2记录两个多项式对应系数值,b1b2记录相应指数值。

参考代码:

#include <cstdio>
#include <vector>
using namespace std;
const int maxn=2001;
double hashtable[maxn]={0};
vector<int> b1,b2,ans;
vector<double> a1,a2;
int main() {
    int k,n;
    double an;
    scanf("%d",&k);
    while(k--){
        scanf("%d%lf",&n,&an);
        a1.push_back(an);
        b1.push_back(n);
    }
    scanf("%d",&k);
    while(k--){
        scanf("%d%lf",&n,&an);
        a2.push_back(an);
        b2.push_back(n);
    }
    for(int i=0;i<a1.size();i++)
        for(int j=0;j<a2.size();j++)
            hashtable[b1[i]+b2[j]]+=a1[i]*a2[j];
    for(int i=maxn-1;i>=0;i--)
        if(hashtable[i]!=0)
            ans.push_back(i);
    printf("%d",ans.size());
    for(int i=0;i<ans.size();i++)
        printf(" %d %.1f",ans[i],hashtable[ans[i]]);
    printf("\n");
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值