1019 General Palindromic Number (20分)
作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai as ∑i=0k (ai bi ). Here, as usual, 0≤ai <b for all i and ak is non-zero. Then N is palindromic if and only if ai =ak−i for all i. Zero is written 0 in any base and is also palindromic by definition.
Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak ak−1 … a0 ". Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1
题意:
将10进制数a,转换成b进制,判断是否对称。
思路:
用取余将余数存在数组中,由于进制数的范围,不能用字符串的方式来记录。
参考代码:
#include <cstdio>
int a,b,arr[100],index=0;
void toradix(int (&array)[100]){
while(a){
array[index++]=a%b;
a/=b;
}
}
bool judge(int array[]){
for(int i=0;i<index/2;i++)
if(array[i]!=array[index-1-i])return false;
return true;
}
int main() {
scanf("%d%d",&a,&b);
toradix(arr);
printf("%s\n",judge(arr)?"Yes":"No");
for(int i=index-1;i>=0;i--){
printf("%d",arr[i]);
i!=0?printf(" "):printf("\n");
}
if(index==0)printf("0");
return 0;
}
如有错误,欢迎指正