【PAT甲级A1034】Head of a Gang (30分)(c++)

1034 Head of a Gang (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time
where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:
For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

题意:

给出n组数据,数据包括哪两个人通话多长时间。找出互相通话人数大于2、时间超出k的团队为犯罪团伙,团队中通话时间最长的人就是头目。如例1中,AAA<->BBB10分钟,BBB<->AAA20分钟,AAA<->CCC40分钟,团队总通话时间70分钟超过了限定的59分钟,其中AAA参与通话70分钟是成员中最多的,所以该团队是犯罪团伙,团伙人数3人,头目是AAA。

思路:

1.利用dfs图遍历,找到连通块进行判断,人数即为深度,为了防止闭环,在dfs是注意要将边给抹掉。
2.由于输入人员姓名不定,可采用set或者map来计算人数。

参考代码:

#include <map>
#include <iostream>
#include <string>
using namespace std;
const int maxn=2000;
int n,k;
int weight[maxn]={0},G[maxn][maxn]={0};
bool flag[maxn]={false};
map<string,int> strtoint;
map<int,string> inttostr;
map<string,int> gang;
int num=0;
int change(const string& str)
{
    if(strtoint.find(str)!=strtoint.end())
        return strtoint[str];
    else {
        strtoint[str]=num;
        inttostr[num]=str;
        return num++;
    }
}
void dfs(int i,int &head,int &number,int &total){
    number++;
    flag[i]=true;
    if(weight[i]>weight[head])
        head=i;
    for(int j=0;j<num;j++){
        if(G[i][j]>0){
            total+=G[i][j];
            G[i][j]=0;
            G[j][i]=0;
            if(!flag[j])
                dfs(j,head,number,total);
        }
    }

}
int main() {
    cin>>n>>k;
    while(n--){
        string str1,str2;
        int w;
        cin>>str1>>str2>>w;
        int id1=change(str1);
        int id2=change(str2);
        weight[id1]+=w;
        weight[id2]+=w;
        G[id1][id2]+=w;
        G[id2][id1]+=w;
    }
    for(int i=0;i<num;i++){
        if(!flag[i]){
            int head=i,number=0,total=0;
            dfs(i,head,number,total);
            if(number>2&&total>k)
                gang[inttostr[head]]=number;
        }
    }
    cout<<gang.size()<<endl;
    if(!gang.empty()){
        for(map<string,int>::iterator it=gang.begin();it!=gang.end();it++)
            cout<<it->first<<" "<<it->second<<endl;
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值