PAT-A1034 Head of a Gang 题目内容及题解

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

题目大意

题目给出一系列的通话记录,从中指出团伙及其头目。团伙是指两人以上组成,他们之间通话时间(权值)的和大于给定阈值的团体,其中头目为其中通话时间最长的。输出团伙数,并按头目的字母顺序输出团伙及其人数。

解题思路

  1. 使用map建立string到int的对应关系方便存储节点;
  2. 读入数据,并生成无向图;
  3. 用广度优先遍历查看其中有多少连通子图,并计算每个连通子图的权值和和成员数,判断是否符合团伙条件,如符合则保存;
  4. 排序并输出,并返回0值。

代码

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<map>

#define maxn 2010

using namespace std;

struct Gang{
    string head;
    int num;
};

map<string,int> Nametonum;
map<int,string> Numtoname;
vector<int> Adj[maxn];
vector<Gang> G;
int N,K;
int PersonNum=0;
int inq[maxn];
int w[maxn];

int Change(string s){
    if(Nametonum.find(s)!=Nametonum.end()){
        return Nametonum[s];
    }else{
        Nametonum[s]=PersonNum;
        Numtoname[PersonNum]=s;
        return PersonNum++;
    }
}

void Init(){
    int i;
    string a,b;
    int t;
    int Na,Nb;
    cin>>N>>K;
    for(i=0;i<N;i++){
        cin>>a>>b>>t;
        Na=Change(a);
        Nb=Change(b);
        Adj[Na].push_back(Nb);
        Adj[Nb].push_back(Na);
        w[Na]+=t;
        w[Nb]+=t;
    }
    return;
}

void BFS(int Person){
    int Queue[maxn];
    Gang temp;
    int front=0,rear=0,now;
    int head,hweight=-1,sum=0;
    int i;
    Queue[rear++]=Person;
    inq[Person]=1;
    while(rear>front){
        now=Queue[front++];
        sum+=w[now];
        if(w[now]>hweight){
            head=now;
            hweight=w[head];
        }
        for(i=0;i<Adj[now].size();i++){
            if(inq[Adj[now][i]]==0){
                Queue[rear++]=Adj[now][i];
                inq[Adj[now][i]]=1;
            }
        }
    }
    if(rear>2&&sum/2>K){
        temp.head=Numtoname[head];
        temp.num=rear;
        G.push_back(temp);
    }
    return;
}

bool cmp(Gang a,Gang b){
    return a.head<b.head;
}

int main(){
    int i;
    Gang temp;
    Init();
    for(i=0;i<PersonNum;i++){
        if(inq[i]==0){
            BFS(i);
        }
    }
    sort(G.begin(),G.end(),cmp);
    cout<<G.size()<<endl;
    for(i=0;i<G.size();i++){
        temp=G[i];
        cout<<temp.head<<" "<<temp.num<<endl;
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值